3D view replaced by red X - Troubleshooting

Symptom

The 3D View is replaced by a red X and a message stating that the system has run out of graphics memory.

 

There are two different possible causes and solutions for this symptom.

Possible Cause 1

If the screen saver displayed prior to the error occurring, Microsoft® DirectX, a utility used to display 3D views, was interrupted.

Solution 1

Try each of the following in the sequence shown until the problem is resolved:

  • Close and reopen the 3D view.
  • Close and reopen the program and the project.
  • Update to the latest version of DirectX.

Possible Cause 2

If the screen saver did not display prior to the error occurring, the system has run out of graphics memory.

Solution 2

Close any unneeded programs that are running on your computer, especially ones that display a lot of graphics. Next, close all 3D views, including those with a red X. Then, reopen the minimum number of 3D views you need.

As a long-term solution, you should consider upgrading your computer's graphics card.